Author Topic: smf version  (Read 3559 times)

âspen

  • Posts: 154
smf version
« on: 31 January 2013 10:27:08 AM »

Hello.  I am one of the 4 admins of forum4.  Yesterday there was a horrible glitch in the forum software.  I've just fixed it, thanks to an extremely helpful discussion thread at

http://www.simplemachines.org/community/index.php?topic=447598.0 (http://www.simplemachines.org/community/index.php?topic=447598.0)

I did what it suggests under "SMF Code Fix" i.e. I edited Load.php replacing all instances of ~^[A-Za-z0-9]{16,32}$~ with ~^[A-Za-z0-9,-]{16,32}$~

Now the forum seems to be working fine again.

I don't know why the glitch suddenly appeared yesterday and guess it was because of a change in the version of php, as explained in that thread.

Anyway, it was very alarming while the glitch was there.  As some of you might have noticed, it was impossible to post.  For admins, it was impossible to get to the admin panels.  The only way I could find to put a holding-message on the forum was by entering it directly into phpMyAdmin.

This has made me think it would be good to have a τεχνική board where we can deal with techinical issues.

And one has come up right away, which is that my admin panel is now saying

"You are using an outdated version of SMF which contains some bugs that have since been fixed. It is recommended that you update your forum to the latest version as soon as possible. It only takes a minute!"

Well should we do this?

~aspen

Mr X

  • unpinged
  • Posts: 306
Re: smf version
« Reply #1 on: 01 February 2013 03:38:37 PM »
the past two times i have posted, i have had and error saying the session had timed out. requiring closing of browser, relogging into the site, all sorts of things just to post once. just letting you know.

mr x.

âspen

  • Posts: 154
Re: smf version
« Reply #2 on: 07 February 2013 02:52:54 PM »

Hi conversation is timeless no need to say it's stalled! I hope the abovementioned glitch has gone away, if anyone notices anything even slightly wrong, please advise.  Haven't yet updated the forum software but suppose I could.